Aartech Canada

            DSC DLS Programming Software

            DLS runs on Microsoft's .NET Framework 4.0 and now using SQLite database. If you do not currently have these software packages installed, they will be installed automatically during the DLS 5 installation process.
             
             Attachments below including a training guide and DLS software.

             

            Here is a brief run-down of the installation steps:
            1. Install the installation executable file above.
            2. The installation process will check for prerequisite applications and as needed they will be downloaded and installed

            Once all the prerequisites and engine files are successfully installed, DLS 5 login window will appear

            If DLS IV is present on the machine, DLS 5 will update DLS IV and uninstall all unnecessary DLS IV components. DLS 5 will automatically convert the DLS IV database from SQL Express to SQLite but will not erase the SQL Express database nor uninstall SQL Express. If SQl Express is no longer required on the machine it can be uninstalled at that point.

            NOTE: SQLite is a light-weight database which does not require any database engine installation.

            Supported Operating Systems
            • Windows XP Professional with Service Pack 3
            • Windows Vista - 32 bit and 64 bit
            • Windows Vista with Service Pack 1 (SP1) - 32 bit and 64 bit
            • Windows Vista with Service Pack 2 (SP2) - 32 bit and 64 bit
            • Windows 7 - 32 bit and 64 bit
            • Windows 7 with Service Pack 1(SP1) - 32 bit and 64 bit
            • Windows 8 - 32 bit and 64 bit
             
             
            Prerequisites
                1. Microsoft .NET Framework 4 Client Profile
                2. Microsoft .NET Framework 4 Extended
                3.Microsoft Visual C++ 2010 Redistributable - x86 10.0.40219
                4.Microsoft Visual C++ 2010 Redistributable - x64 10.0.40219 (DLS INT only)

            These prerequisites are automatically downloaded (if necessary) and installed under normal circumstances.

            However, if you are having trouble with the automated installation of prerequisites, you may download them directly from Microsoft.
            They must be installed in the order listed below.

                1. Microsoft .NET Framework 4 Client Profile
                 - http://www.microsoft.com/download/details.aspx?id=24872

                2. Microsoft .NET Framework 4 Extended
                 - http://www.microsoft.com/download/details.aspx?id=17718

                3. Microsoft Visual C++ 2010 Redistributable - x86 10.0.40219
                 - http://www.microsoft.com/download/details.aspx?id=8328
             
                4. DLS5 Software
            Updated: 14 Aug 2019 08:42 AM
            Helpful?  
            Help us to make this article better
            0 0